using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^Thanks\s*,\s*([A-Z]?[a-z]*)\s*[^!]?$";
string substitution = @"Thanks, [NAME]";
string input = @"Thanks, Bob
Thanks, Bob.
Thanks, Bob!";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}