import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^.*\\?)([^\\?].*(?=<))(<\\/br>)";
final String string = "Hoeveel is vier keer vijfentwintig? Honderd</br>";
final String subst = "<span title = \"$2\">$1</span>$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}