#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[-+]?(?:\d{1,3})(?:,\d{3})*(?:\.\d{1,2})?%$"
Local $sString = "0%" & @CRLF & _
"5%" & @CRLF & _
"12%" & @CRLF & _
"3.14%" & @CRLF & _
"-7%" & @CRLF & _
"-150%" & @CRLF & _
"100%" & @CRLF & _
"1,000%" & @CRLF & _
"-4,423,423.40%" & @CRLF & _
"52,123,123,123.00%" & @CRLF & _
"5,332.00%" & @CRLF & _
"" & @CRLF & _
"1000%" & @CRLF & _
"1.000%" & @CRLF & _
"1000,24%"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")