import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[-+]?(?:\\d{1,3})(?:,\\d{3})*(?:\\.\\d{1,2})?%$";
final String string = "0%\n"
+ "5%\n"
+ "12%\n"
+ "3.14%\n"
+ "-7%\n"
+ "-150%\n"
+ "100%\n"
+ "1,000%\n"
+ "-4,423,423.40%\n"
+ "52,123,123,123.00%\n"
+ "5,332.00%\n\n"
+ "1000%\n"
+ "1.000%\n"
+ "1000,24%";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}