import re
regex = re.compile(r"^[-+]?(?:\d{1,3})(?:,\d{3})*(?:\.\d{1,2})?%$", flags=re.MULTILINE)
test_str = ("0%\n"
"5%\n"
"12%\n"
"3.14%\n"
"-7%\n"
"-150%\n"
"100%\n"
"1,000%\n"
"-4,423,423.40%\n"
"52,123,123,123.00%\n"
"5,332.00%\n\n"
"1000%\n"
"1.000%\n"
"1000,24%")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")