use strict;
my $str = '0%
5%
12%
3.14%
-7%
-150%
100%
1,000%
-4,423,423.40%
52,123,123,123.00%
5,332.00%
1000%
1.000%
1000,24%';
my $regex = qr/^[-+]?(?:\d{1,3})(?:,\d{3})*(?:\.\d{1,2})?%$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}