const regex = /^[-+]?(?:\d{1,3})(?:,\d{3})*(?:\.\d{1,2})?%$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[-+]?(?:\\d{1,3})(?:,\\d{3})*(?:\\.\\d{1,2})?%$', 'gm')
const str = `0%
5%
12%
3.14%
-7%
-150%
100%
1,000%
-4,423,423.40%
52,123,123,123.00%
5,332.00%
1000%
1.000%
1000,24%`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}