// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[-+]?(?:\d{1,3})(?:,\d{3})*(?:\.\d{1,2})?%$").unwrap();
let string = "0%
5%
12%
3.14%
-7%
-150%
100%
1,000%
-4,423,423.40%
52,123,123,123.00%
5,332.00%
1000%
1.000%
1000,24%";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}