re = /^zh-han[st]\//m
str = 'These are URL paths:
zh-hans/blog/uncategorized/123
zh-hant/blog/uncategorized/456
en/blog/uncategorized/789'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end