// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^zh-han[st]/").unwrap();
let string = "These are URL paths:
zh-hans/blog/uncategorized/123
zh-hant/blog/uncategorized/456
en/blog/uncategorized/789";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}