#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:host-vpp1out .*|\G(?!^))\n\s+L3\s+(\d[\d.:\/a-z]+)\/\d+"
Local $sString = "VirtualFuncEthernet0/7/0.2001 (up):" & @CRLF & _
" L3 1.1.2.2/24 ip4 table-id 8 fib-idx 2" & @CRLF & _
" L3 2001:db8:0:1:1:1:2:2/112 ip6 table-id 8 fib-idx 1" & @CRLF & _
"VirtualFuncEthernet0/9/0 (dn):" & @CRLF & _
"host-vpp1out (up):" & @CRLF & _
" L3 1.1.1.1/24" & @CRLF & _
" L3 1.1.2.1/24" & @CRLF & _
" L3 2001:db8:0:1:1:1:1:1/112" & @CRLF & _
" L3 2001:db8:0:1:1:1:2:1/112" & @CRLF & _
"local0 (dn):" & @CRLF & _
"loop0 (up):" & @CRLF & _
" L3 1.1.1.1/32 ip4 table-id 7 fib-idx 1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")