use strict;
my $str = 'VirtualFuncEthernet0/7/0.2001 (up):
L3 1.1.2.2/24 ip4 table-id 8 fib-idx 2
L3 2001:db8:0:1:1:1:2:2/112 ip6 table-id 8 fib-idx 1
VirtualFuncEthernet0/9/0 (dn):
host-vpp1out (up):
L3 1.1.1.1/24
L3 1.1.2.1/24
L3 2001:db8:0:1:1:1:1:1/112
L3 2001:db8:0:1:1:1:2:1/112
local0 (dn):
loop0 (up):
L3 1.1.1.1/32 ip4 table-id 7 fib-idx 1';
my $regex = qr/(?:host-vpp1out .*|\G(?!^))\n\s+L3\s+(\d[\d.:\/a-z]+)\/\d+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}