re = /(?:host-vpp1out .*|\G(?!^))\n\s+L3\s+(\d[\d.:\/a-z]+)\/\d+/m
str = 'VirtualFuncEthernet0/7/0.2001 (up):
L3 1.1.2.2/24 ip4 table-id 8 fib-idx 2
L3 2001:db8:0:1:1:1:2:2/112 ip6 table-id 8 fib-idx 1
VirtualFuncEthernet0/9/0 (dn):
host-vpp1out (up):
L3 1.1.1.1/24
L3 1.1.2.1/24
L3 2001:db8:0:1:1:1:1:1/112
L3 2001:db8:0:1:1:1:2:1/112
local0 (dn):
loop0 (up):
L3 1.1.1.1/32 ip4 table-id 7 fib-idx 1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end