import Foundation
let pattern = #"(?:host-vpp1out .*|\G(?!^))\n\s+L3\s+(\d[\d.:\/a-z]+)\/\d+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
VirtualFuncEthernet0/7/0.2001 (up):
L3 1.1.2.2/24 ip4 table-id 8 fib-idx 2
L3 2001:db8:0:1:1:1:2:2/112 ip6 table-id 8 fib-idx 1
VirtualFuncEthernet0/9/0 (dn):
host-vpp1out (up):
L3 1.1.1.1/24
L3 1.1.2.1/24
L3 2001:db8:0:1:1:1:1:1/112
L3 2001:db8:0:1:1:1:2:1/112
local0 (dn):
loop0 (up):
L3 1.1.1.1/32 ip4 table-id 7 fib-idx 1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)