import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:host-vpp1out .*|\\G(?!^))\\n\\s+L3\\s+(\\d[\\d.:\\/a-z]+)\\/\\d+";
final String string = "VirtualFuncEthernet0/7/0.2001 (up):\n"
+ " L3 1.1.2.2/24 ip4 table-id 8 fib-idx 2\n"
+ " L3 2001:db8:0:1:1:1:2:2/112 ip6 table-id 8 fib-idx 1\n"
+ "VirtualFuncEthernet0/9/0 (dn):\n"
+ "host-vpp1out (up):\n"
+ " L3 1.1.1.1/24\n"
+ " L3 1.1.2.1/24\n"
+ " L3 2001:db8:0:1:1:1:1:1/112\n"
+ " L3 2001:db8:0:1:1:1:2:1/112\n"
+ "local0 (dn):\n"
+ "loop0 (up):\n"
+ " L3 1.1.1.1/32 ip4 table-id 7 fib-idx 1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}