using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:host-vpp1out .*|\G(?!^))\n\s+L3\s+(\d[\d.:\/a-z]+)\/\d+";
string input = @"VirtualFuncEthernet0/7/0.2001 (up):
L3 1.1.2.2/24 ip4 table-id 8 fib-idx 2
L3 2001:db8:0:1:1:1:2:2/112 ip6 table-id 8 fib-idx 1
VirtualFuncEthernet0/9/0 (dn):
host-vpp1out (up):
L3 1.1.1.1/24
L3 1.1.2.1/24
L3 2001:db8:0:1:1:1:1:1/112
L3 2001:db8:0:1:1:1:2:1/112
local0 (dn):
loop0 (up):
L3 1.1.1.1/32 ip4 table-id 7 fib-idx 1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}