#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[A-Z]{2};\d;\d{5};\d{3};"
Local $sString = "AB;2;43234;343;" & @CRLF & _
"CD;4;41234;443;" & @CRLF & _
"FE;5;53234;543;" & @CRLF & _
"23;6;25522;354;" & @CRLF & _
"GB;j;234;11;" & @CRLF & _
"asg;;ad;v;a;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")