use strict;
my $str = 'AB;2;43234;343;
CD;4;41234;443;
FE;5;53234;543;
23;6;25522;354;
GB;j;234;11;
asg;;ad;v;a;';
my $regex = qr/[A-Z]{2};\d;\d{5};\d{3};/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}