package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Z]{2};\d;\d{5};\d{3};`)
var str = `AB;2;43234;343;
CD;4;41234;443;
FE;5;53234;543;
23;6;25522;354;
GB;j;234;11;
asg;;ad;v;a;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}