re = /[A-Z]{2};\d;\d{5};\d{3};/m
str = 'AB;2;43234;343;
CD;4;41234;443;
FE;5;53234;543;
23;6;25522;354;
GB;j;234;11;
asg;;ad;v;a;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end