$re = '/[A-Z]{2};\d;\d{5};\d{3};/m';
$str = 'AB;2;43234;343;
CD;4;41234;443;
FE;5;53234;543;
23;6;25522;354;
GB;j;234;11;
asg;;ad;v;a;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);