import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Z]{2};\\d;\\d{5};\\d{3};";
final String string = "AB;2;43234;343;\n"
+ "CD;4;41234;443;\n"
+ "FE;5;53234;543;\n"
+ "23;6;25522;354;\n"
+ "GB;j;234;11;\n"
+ "asg;;ad;v;a;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}