$re = '/^[A-Z]{2}\d{2} (?:\d{4} ){3}\d{4}(?: \d\d?)?$/m';
$str = 'DE89 3704 0044 0532 0130 00
AT61 1904 3002 3457 3201
FR14 2004 1010 0505 0001 3
R14 2004 1010 0505 0001 3
FR14 2004 1010 0505 0001 444
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);