using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(\s*(.+?)\s*\?\s*(\(\s*)?(?(-1)(.+?)\s*\)|(.+?))\s*\:\s*(\(\s*)?(?(-1)(.+?)\s*\)|(.+?))\s*\)";
string input = @"( myCondition ? truePart : elsePart ) //done!
( myCondition ? truePart : ( myCondition2 ? truePart2 : falsePart2 ) ) //done!
( myCondition ? ( myConditionT ? truePartT : falsePartT ) : ( myConditionF ? truePartF : falsePartF ) ) //done!
( myCondition ? ( myConditionT ? truePartT : falsePartT ) : falsePartF ) //done!
\(\s*(.+?)\s*\?\s*(.+?)\s*\:\s*(\(\s*)?(?(-1)(.+?)\s*\)|(.+?))\s*\)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}