$re = '/\(\s*(.+?)\s*\?\s*(\(\s*)?(?(-1)(.+?)\s*\)|(.+?))\s*\:\s*(\(\s*)?(?(-1)(.+?)\s*\)|(.+?))\s*\)/';
$str = '( myCondition ? truePart : elsePart ) //done!
( myCondition ? truePart : ( myCondition2 ? truePart2 : falsePart2 ) ) //done!
( myCondition ? ( myConditionT ? truePartT : falsePartT ) : ( myConditionF ? truePartF : falsePartF ) ) //done!
( myCondition ? ( myConditionT ? truePartT : falsePartT ) : falsePartF ) //done!
\\(\\s*(.+?)\\s*\\?\\s*(.+?)\\s*\\:\\s*(\\(\\s*)?(?(-1)(.+?)\\s*\\)|(.+?))\\s*\\)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);