import re
regex = re.compile(r"\(\s*(.+?)\s*\?\s*(\(\s*)?(?(-1)(.+?)\s*\)|(.+?))\s*\:\s*(\(\s*)?(?(-1)(.+?)\s*\)|(.+?))\s*\)")
test_str = ("( myCondition ? truePart : elsePart ) //done!\n\n"
"( myCondition ? truePart : ( myCondition2 ? truePart2 : falsePart2 ) ) //done!\n\n"
"( myCondition ? ( myConditionT ? truePartT : falsePartT ) : ( myConditionF ? truePartF : falsePartF ) ) //done!\n\n"
"( myCondition ? ( myConditionT ? truePartT : falsePartT ) : falsePartF ) //done!\n\n"
"\\(\\s*(.+?)\\s*\\?\\s*(.+?)\\s*\\:\\s*(\\(\\s*)?(?(-1)(.+?)\\s*\\)|(.+?))\\s*\\)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")