// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\(\s*(.+?)\s*\?\s*(\(\s*)?(?(-1)(.+?)\s*\)|(.+?))\s*\:\s*(\(\s*)?(?(-1)(.+?)\s*\)|(.+?))\s*\)").unwrap();
let string = "( myCondition ? truePart : elsePart ) //done!
( myCondition ? truePart : ( myCondition2 ? truePart2 : falsePart2 ) ) //done!
( myCondition ? ( myConditionT ? truePartT : falsePartT ) : ( myConditionF ? truePartF : falsePartF ) ) //done!
( myCondition ? ( myConditionT ? truePartT : falsePartT ) : falsePartF ) //done!
\\(\\s*(.+?)\\s*\\?\\s*(.+?)\\s*\\:\\s*(\\(\\s*)?(?(-1)(.+?)\\s*\\)|(.+?))\\s*\\)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}