#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*[^,\s][^,]*$"
Local $sString = " adadadad dfgdfgdgddgdggdd," & @CRLF & _
" d f" & @CRLF & _
"" & @CRLF & _
"d,b" & @CRLF & _
"d bdbf dsdf " & @CRLF & _
"," & @CRLF & _
"g,,,,,d" & @CRLF & _
",,,,,,," & @CRLF & _
"b,d" & @CRLF & _
"dda asdd dadadad"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")