// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\s*[^,\s][^,]*$").unwrap();
let string = " adadadad dfgdfgdgddgdggdd,
d f
d,b
d bdbf dsdf
,
g,,,,,d
,,,,,,,
b,d
dda asdd dadadad";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}