import re
regex = re.compile(r"^\s*[^,\s][^,]*$", flags=re.MULTILINE)
test_str = (" adadadad dfgdfgdgddgdggdd,\n"
" d f\n\n"
"d,b\n"
"d bdbf dsdf \n"
",\n"
"g,,,,,d\n"
",,,,,,,\n"
"b,d\n"
"dda asdd dadadad")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")