import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*[^,\\s][^,]*$";
final String string = " adadadad dfgdfgdgddgdggdd,\n"
+ " d f\n\n"
+ "d,b\n"
+ "d bdbf dsdf \n"
+ ",\n"
+ "g,,,,,d\n"
+ ",,,,,,,\n"
+ "b,d\n"
+ "dda asdd dadadad";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}