re = /^\s*[^,\s][^,]*$/m
str = ' adadadad dfgdfgdgddgdggdd,
d f
d,b
d bdbf dsdf
,
g,,,,,d
,,,,,,,
b,d
dda asdd dadadad'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end