using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?:(?<Name>[[:alpha:]]+)[ ]*\(['""]?(?<Value>[^)'""]*)['""]?\))|(?:(?<Null>(?:NOT NULL|NULL))))";
string input = @"VARCHAR(5,2) NoT NULL DEFAULT ('Vale urpa rdefaut')";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}