const regex = /(?:(?:(?<Name>[[:alpha:]]+)[ ]*\(['"]?(?<Value>[^)'"]*)['"]?\))|(?:(?<Null>(?:NOT NULL|NULL))))/gis;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:(?<Name>[[:alpha:]]+)[ ]*\\([\'"]?(?<Value>[^)\'"]*)[\'"]?\\))|(?:(?<Null>(?:NOT NULL|NULL))))', 'gis')
const str = `VARCHAR(5,2) NoT NULL DEFAULT ('Vale urpa rdefaut')`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}