import re
regex = re.compile(r"(?:(?:(?<Name>[[:alpha:]]+)[ ]*\(['\"]?(?<Value>[^)'\"]*)['\"]?\))|(?:(?<Null>(?:NOT NULL|NULL))))", flags=re.IGNORECASE | re.DOTALL)
test_str = "VARCHAR(5,2) NoT NULL DEFAULT ('Vale urpa rdefaut')"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")