$re = '/(?:(?:(?<Name>[[:alpha:]]+)[ ]*\([\'"]?(?<Value>[^)\'"]*)[\'"]?\))|(?:(?<Null>(?:NOT NULL|NULL))))/is';
$str = 'VARCHAR(5,2) NoT NULL DEFAULT (\'Vale urpa rdefaut\')';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);