package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)(?:(?:(?<Name>[[:alpha:]]+)[ ]*\(['"]?(?<Value>[^)'"]*)['"]?\))|(?:(?<Null>(?:NOT NULL|NULL))))`)
var str = `VARCHAR(5,2) NoT NULL DEFAULT ('Vale urpa rdefaut')`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}