re = /(?:(?:(?<Name>[[:alpha:]]+)[ ]*\(['"]?(?<Value>[^)'"]*)['"]?\))|(?:(?<Null>(?:NOT NULL|NULL))))/i
str = 'VARCHAR(5,2) NoT NULL DEFAULT (\'Vale urpa rdefaut\')'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end