#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!.)([\s]*)(go|GO)\s*([\r\n])?"
Local $sString = "use SCRATCH " & @CRLF & _
"GO; " & @CRLF & _
"--go " & @CRLF & _
"set nocount ON ;go; " & @CRLF & _
"go " & @CRLF & _
"' go ' " & @CRLF & _
"'go' " & @CRLF & _
"'go " & @CRLF & _
"go' " & @CRLF & _
"create table gonogo ( go int null, nogo int null) " & @CRLF & _
"GO " & @CRLF & _
"" & @CRLF & _
"insert INTO mungbean VALUES (1); go " & @CRLF & _
"GO " & @CRLF & _
"; " & @CRLF & _
"select * from mungbean " & @CRLF & _
"go " & @CRLF & _
"" & @CRLF & _
" go " & @CRLF & _
" go; " & @CRLF & _
" ' " & @CRLF & _
"select go from go" & @CRLF & _
"go " & @CRLF & _
"select go from allgo" & @CRLF & _
" GO" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")