const regex = /(?<!.)([\s]*)(go|GO)\s*([\r\n])?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!.)([\\s]*)(go|GO)\\s*([\\r\\n])?', 'gm')
const str = `use SCRATCH
GO;
--go
set nocount ON ;go;
go
' go '
'go'
'go
go'
create table gonogo ( go int null, nogo int null)
GO
insert INTO mungbean VALUES (1); go
GO
;
select * from mungbean
go
go
go;
'
select go from go
go
select go from allgo
GO
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}