import re
regex = re.compile(r"(?<!.)([\s]*)(go|GO)\s*([\r\n])?", flags=re.MULTILINE)
test_str = ("use SCRATCH \n"
"GO; \n"
"--go \n"
"set nocount ON ;go; \n"
"go \n"
"' go ' \n"
"'go' \n"
"'go \n"
"go' \n"
"create table gonogo ( go int null, nogo int null) \n"
"GO \n\n"
"insert INTO mungbean VALUES (1); go \n"
"GO \n"
"; \n"
"select * from mungbean \n"
"go \n\n"
" go \n"
" go; \n"
" ' \n"
"select go from go\n"
"go \n"
"select go from allgo\n"
" GO\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")