use strict;
my $str = 'use SCRATCH
GO;
--go
set nocount ON ;go;
go
\' go \'
\'go\'
\'go
go\'
create table gonogo ( go int null, nogo int null)
GO
insert INTO mungbean VALUES (1); go
GO
;
select * from mungbean
go
go
go;
\'
select go from go
go
select go from allgo
GO
';
my $regex = qr/(?<!.)([\s]*)(go|GO)\s*([\r\n])?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}