import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!.)([\\s]*)(go|GO)\\s*([\\r\\n])?";
final String string = "use SCRATCH \n"
+ "GO; \n"
+ "--go \n"
+ "set nocount ON ;go; \n"
+ "go \n"
+ "' go ' \n"
+ "'go' \n"
+ "'go \n"
+ "go' \n"
+ "create table gonogo ( go int null, nogo int null) \n"
+ "GO \n\n"
+ "insert INTO mungbean VALUES (1); go \n"
+ "GO \n"
+ "; \n"
+ "select * from mungbean \n"
+ "go \n\n"
+ " go \n"
+ " go; \n"
+ " ' \n"
+ "select go from go\n"
+ "go \n"
+ "select go from allgo\n"
+ " GO\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}