#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\w)[A-G](?!\w)"
Local $sString = "Capo 1st fret" & @CRLF & _
"" & @CRLF & _
"[Verse]" & @CRLF & _
"" & @CRLF & _
"C G Am" & @CRLF & _
"" & @CRLF & _
"If I had to live my life without you near me" & @CRLF & _
"" & @CRLF & _
"Em F C" & @CRLF & _
"" & @CRLF & _
"The days would all be empty" & @CRLF & _
"" & @CRLF & _
"Dm G" & @CRLF & _
"" & @CRLF & _
"The nights would seem so long"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")