use strict;
my $str = 'Capo 1st fret
[Verse]
C G Am
If I had to live my life without you near me
Em F C
The days would all be empty
Dm G
The nights would seem so long';
my $regex = qr/(?<!\w)[A-G](?!\w)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}