using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\w)[A-G](?!\w)";
string input = @"Capo 1st fret
[Verse]
C G Am
If I had to live my life without you near me
Em F C
The days would all be empty
Dm G
The nights would seem so long";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}