$re = '/(?<!\w)[A-G](?!\w)/m';
$str = 'Capo 1st fret
[Verse]
C G Am
If I had to live my life without you near me
Em F C
The days would all be empty
Dm G
The nights would seem so long';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);