const regex = /(?<!\w)[A-G](?!\w)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\w)[A-G](?!\\w)', 'gm')
const str = `Capo 1st fret
[Verse]
C G Am
If I had to live my life without you near me
Em F C
The days would all be empty
Dm G
The nights would seem so long`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}