import re
regex = re.compile(r"(?<!\w)[A-G](?!\w)", flags=re.MULTILINE)
test_str = ("Capo 1st fret\n\n"
"[Verse]\n\n"
"C G Am\n\n"
"If I had to live my life without you near me\n\n"
"Em F C\n\n"
"The days would all be empty\n\n"
"Dm G\n\n"
"The nights would seem so long")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")