# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d)[\s.]+(?=\d)/$1/gm;t' <<< "This is an 8-string 12.34.5678; and this is another 13-string 1234 5678 9123 0 okay?"